
<!DOCTYPE html>
<html lang="en">

<!-- Faster page load hack -->
<!--[if IE]><![endif]-->

<head>
<!-- Begin: head -->
<!-- z2_comm_head_module_v2 start -->
<meta charset="utf-8" />

<style>
*{margin:0 auto;padding:0;outline:0 none}.clearfix{zoom:1}.clearfix:after{content:".";display:block;height:0;clear:both;visibility:hidden}html{font-size:100%;font-size:100%;-webkit-text-size-adjust:100%;-ms-text-size-adjust:100%}html body{font-size:62.5%;background-color:#fafafa;margin:0;padding:0;font-family:Helvetica,Arial,sans-serif}article,aside,details,figcaption,figure,footer,header,hgroup,nav,section,summary{display:block}section footer{padding:6px 0}.align_left,.alpha{text-align:left}.align_right{text-align:right}.align_center{text-align:center}.float_left{float:left}.float_right{float:right}article a h1,article a h2{color:#000;text-decoration:none}article header h1{font-weight:700;font-weight:700;font-size:10.5pt;text-transform:inherit!important}article a h1,article a h2{color:#000;text-decoration:none}html body h1{text-shadow:0 1px 1px #fff}@media screen and (min-width:1024px){#banner{min-height:90px;}}
</style>

<style type="text/css" data-tippy-stylesheet>
.tippy-box[data-theme~=zacks]{min-width:301px;background-color:#fff}.tippy-box[data-theme~=zacks] .tippy-content{padding:0!important}
</style>

<!-- Combined and Minified CSS file for all generator pages --> 
<link rel="stylesheet" href="https://staticx.zacks.com/min/z3-min.css?v=20220915" />
  
<!-- Conditional CSS for IE versions -->
<!--[if lt IE 7]><style type="text/css"> .hide_lte_ie6 { display:none; } </style><![endif]-->
<!--[if lte IE 7]><style type="text/css"> .hide_lte_ie7 { display:none; } </style><![endif]-->
<!--[if lte IE 8]><style type="text/css"> .hide_lte_ie8 { display:none; } </style><![endif]-->
<!--[if lte IE 9]><style type="text/css"> .hide_lte_ie9 { display:none; } </style><![endif]-->
<!--[if IE 10]><style type="text/css"> .hide_lte_ie10 { display:none; } </style><![endif]-->
<!--[if IE]><![endif]-->
<!-- End conditional CSS for IE versions -->

    <!-- DC PAGE ID : 194  -->
    <meta name="generator" content="WebGenerator" />
    <meta name="description" content="Target Hospitality (TH) has received quite a bit of attention from Zacks.com users lately. Therefore, it is wise to be aware of the facts that can impact the stock's prospects." />
    <meta name="keywords" content="stock, stocks, investment, investment advice, investing, online trading, online investment, online stock trading, stock market, financial, financial planning, quote, quotes, stock quotes" />
    <title>Is Most-Watched Stock Target Hospitality Corp. (TH) Worth Betting on Now? - September 16, 2022 - Zacks.com</title>
    <meta name="date" content="Fri, 16 Sep 2022 16:37:34" />
    <meta name="last-modified" content="Fri, 16 Sep 2022 16:37:34;" />
    <meta http-equiv="last-modified" content="Fri, 16 Sep 2022 16:37:34" />
    <meta property="fb:admins" content="20922385" />
    <meta property="article:publisher" content="https://www.facebook.com/ZacksInvestmentResearch" />


    <meta property="og:site_name" content="Zacks Investment Research" />
    
    
    
<meta property="og:title" content="Is Most-Watched Stock Target Hospitality Corp. (TH) Worth Betting on Now?"/>
<meta property="og:type" content="article"/>
<meta property="og:image" content="https://staticx-tuner.zacks.com/images/default_article_images/default253.jpg"/>
<meta property="og:url" content="https://www.zacks.com/stock/news/1981366/is-most-watched-stock-target-hospitality-corp-th-worth-betting-on-now"/>
<meta property="og:description" content="Target Hospitality (TH) has received quite a bit of attention from Zacks.com users lately. Therefore, it is wise to be aware of the facts that can impact the stock's prospects."/>

    
<meta name="twitter:card" content="summary_large_image">



    <meta name="twitter:site" content="@ZacksInvestment">
<meta name="twitter:title" content="Is Most-Watched Stock Target Hospitality Corp. (TH) Worth Betting on Now?"/>
<meta name="twitter:image" content="https://staticx-tuner.zacks.com/images/default_article_images/default253.jpg"/>
<meta name="twitter:description" content="Target Hospitality (TH) has received quite a bit of attention from Zacks.com users lately. Therefore, it is wise to be aware of the facts that can impact the stock's prospects."/>

    
    <meta name="news_keywords" content="TH, Target Hospitality Corp., Business,Markets,Investing,Stocks,Stock Market,Stock Market News,Business News ">
    <link rel="publisher" href="https://plus.google.com/118293395770893367580" />
    <meta name="msvalidate.01" content="91D8CCE675E89439C48AA39EBAF6988D" />
    <meta name="alexaVerifyID" content="KIaduWIc88WqN22kuP9vXoMfUNg" />
    
    <!-- Article Structured Data -->
    <script type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "mainEntityOfPage": "https://www.zacks.com/stock/news/1981366/is-most-watched-stock-target-hospitality-corp-th-worth-betting-on-now",
        "headline": "Is Most-Watched Stock Target Hospitality Corp. (TH) Worth Betting on Now?",
        "datePublished": "2022-09-16",
        "dateModified": "2022-09-16",
        "description": "Target Hospitality (TH) has received quite a bit of attention from Zacks.com users lately. Therefore, it is wise to be aware of the facts that can impact the stock's prospects.",
        "author": {
          "@type": "Person",
          "name": "Zacks Equity Research"
        },
        "publisher": {
          "@type": "Organization",
          "name": "Zacks Investment Research",
          "logo": {
            "@type": "ImageObject",
            "url": "https://staticx.zacks.com/images/zacks/logos/logo2014_tagstack-sitehead_232x92_2x.png",
            "width": "232px",
            "height": "92px"
          }
        },
        "image": {
          "@type": "ImageObject",
          "url": "https://staticx-tuner.zacks.com/images/default_article_images/default253.jpg",
          "height": "603px",
          "width": "1000px"
        },
        "mentions":[
                {
                  "@type": "Corporation",
                  "tickerSymbol": "TH",
                  "url": "www.zacks.com/stock/quote/TH"
                 }
        ]
       
      }
      </script>
    <link rel="canonical" href="https://www.zacks.com/stock/news/1981366/is-most-watched-stock-target-hospitality-corp-th-worth-betting-on-now" />
    <meta name="syndication-source" content="https://www.zacks.com/stock/news/1981366/is-most-watched-stock-target-hospitality-corp-th-worth-betting-on-now"><meta name="apple-itunes-app" content="app-id=731593509">    <link rel="amphtml" href="https://www.zacks.com/amp/stock/news/1981366/is-most-watched-stock-target-hospitality-corp-th-worth-betting-on-now" />

<!-- used by smart phones and tables -->
<meta name="author" content="Zacks Investment Research" />
<meta name="copyright" content="&copy; 2013 Zacks Investment Research" />
<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no" />
<link rel="icon" href="https://staticx.zacks.com/images/zacks/logos/favicon_1x_16x16.ico" type="image/x-icon" />
<link rel="shortcut icon" href="https://staticx.zacks.com/images/zacks/logos/favicon_1x_16x16.ico" type="image/x-icon" />

<!-- For non-Retina iPhone, iPod Touch, and Android 2.1+ devices: -->
<link rel="apple-touch-icon-precomposed" href="https://staticx.zacks.com/images/zacks/logos/logo_apple-touch-icon-57x57precomposed.png" />
<!-- For first- and second-generation iPad: -->
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://staticx.zacks.com/images/zacks/logos/logo_apple-touch-icon-72x72precomposed.png" />
<!-- For iPhone with high-resolution Retina display: -->
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://staticx.zacks.com/images/zacks/logos/logo_apple-touch-icon-114x114-precomposed.png" />
<!-- For third-generation iPad with high-resolution Retina display: -->
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://staticx.zacks.com/images/zacks/logos/logo_apple-touch-icon-144x144-precomposed.png" />


<!-- DC Page id : 194 -->

<!--[if IE]>
<script async src="https://staticx.zacks.com/js/html5shiv.js"></script>
<![endif]-->

<!-- z2_head_v2.phtml -->
<script defer src="https://staticx.zacks.com/js/jquery/jquery.min.js?v=20220915"></script>
<script src="//assets.adobedtm.com/launch-ENf92a8a0f57b7412a8d05119401e8c329.min.js" async></script>
<script defer src="https://staticx.zacks.com/min/jquery-ui-min.js?v=20220915"></script>
<script defer src="https://staticx.zacks.com/min/z2-min.js?v=20220915"></script>
<script>
var WIDGET_PATH_JS          = 'widget3.zacks.com';
var WIDGET3_PATH_JS         = 'widget3.zacks.com';
var PROTOCOL_JS             = 'https://';
var HTTP_PROTOCOL_JS        = 'https://';
var SITE_ROOT_PROTOCOL      = 'https://www.zacks.com/';
var STATIC_CONTENT_ROOT_JS  = 'https://staticx.zacks.com';
var STATIC_TUNER_IMAGE_ROOT = 'https://staticx-tuner.zacks.com/images/';
var DEFAULT_HOST            = 'www.zacks.com';
var PAGE_TYPE               = 'stock';
var PAGE_SUB_SECTION        = 'news';
var HOVERQUOTE_IDENTIFIER   = 'blog-tale_of_the_tape';
var ELK_VERSION             = '20220624';
</script>
<script>
var appendNumber = 4;
var prependNumber = 1;
</script><link media="all" rel="stylesheet" type="text/css" href="https://staticx.zacks.com/css/zacks/css3/styles/commentary-main.css?v=20220915" /><script defer src="https://staticx.zacks.com/min/commentary-min.js?v=20220915"></script><script defer src="https://staticx.zacks.com/js/zacks/inline/commentary.js?v=20220915"></script><script defer src="https://staticx.zacks.com/js/zacks/article_ads.js?v=20220915"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-2333136737514314" crossorigin="anonymous"></script>
<script>
var _site_id = '2802258';
var _dcPageId = '194';
var _premDcPageId = '467';
var _isLoggedIn = 'false';
var _isLoggedInType  = '';
var _ticker_string   = '';
var _vertical_name   = 'ZComCommentary';
var _vertical_id     = '10';
var freestar = freestar || {};
freestar.queue = freestar.queue || [];
freestar.config = freestar.config || {};
freestar.config.enabled_slots = [];
freestar.initCallback = function() {
(freestar.config.enabled_slots.length === 0) ? freestar.initCallbackCalled = false: freestar.newAdSlots(freestar.config.enabled_slots) };
// if a user is "ultimate" they get no ads
// if a user is logged out or if they have a paid subscription (non-ultimate), they will not get sidewalls
// if a user is logged in but "free," they will get all ads

if (_isLoggedInType != 'Ultimate') 
{
    !function(a, bb) 
    {
    
        var cc = bb.getElementsByTagName("script")[0],
        dd = bb.createElement("script"),
        ee = "https://a.pub.network/zacks-com";
        ee += freestar.debug ? "/qa/pubfig.min.js" : "/pubfig.min.js", dd.async = !0, dd.src = ee, cc.parentNode.insertBefore(dd, cc)
    }(window, document);
    
    freestar.config.channel = (window.location.pathname == '/' && window.location.host == 'www.zacks.com') ? 'ZComHome' : _vertical_name;
    
    freestar.queue.push(function() 
    {
        googletag.pubads().setTargeting('ticker', _ticker_string);
    });   
    
}

if(_isLoggedIn == 'false' || _isLoggedIn == 'paid' || _isLoggedIn == 'premium') 
    {
        freestar.config.disabledProducts = {
        sideWall: true
        }
    }


</script>
<!-- z2_comm_head_module_v2 end -->

<!-- End: head -->
</head>

<body>


<!-- Begin: top_navigation-->
<!-- z2_top_nav start -->
<div class="skipnav"><a href="#main_content">Skip to main content</a></div>

<div class="disclosure-fixed-slab" role="region" aria-label="Cookie Consent">
    <p>We use cookies to understand how you use our site and to improve your experience. This includes personalizing content and advertising. To learn more, <a href="https://www.zacks.com/privacy.php#how-to-use-cookies">click here</a>. By continuing to use our site, you accept our use of cookies, revised <a href="/privacy.php">Privacy Policy</a> and <a href="/terms_of_service">Terms of Service</a>.</p>
    <div>
        <button id="accept_cookie" name="accept_cookie">I accept</button>
        <button class="close" aria-label="Close">X</button>
    </div>
</div>


<section class="clearfix top-header-section">
<div class="header-logos"><a class="mobile_logo" href="/" rel="home" role="link"><img src="https://staticx.zacks.com/images/zacks/logos/zacks_logo_200x57.png" width="200" height="57" alt="Zacks Investment Research Home" title=""></a> </div>
<ul class="user-menu_list "><li><a href="https://www.zacks.com/registration_info.php">Join Now</a></li>
                    <li id="mob_log_me_in">
                        <a href="#" class="mobile_login_box">Sign In</a>
                        <!-- Begin: Login form -->
                        <div id="mob_login_form">
                            <form name="jslogin_form" class="jslogin_form" method="post" action="https://www.zacks.com/stock/news/1981366/is-most-watched-stock-target-hospitality-corp-th-worth-betting-on-now?" onsubmit="return JSloginCheck(this);">
                            <input type="hidden" name="force_login" value="true" class="hidden">
                            
                                <h1>Member Sign In</h1>
                                
                                <div class="form-field float-label">                                    
                                    <input id="username" type="text" name="username" placeholder="Username or Email Address">
                                    <label for="username">Username or Email Address</label>
                                </div>
                                
                                <div class="form-field float-label">                                    
                                    <input id="password" type="password" name="password" placeholder="Password"> 
                                    <label for="password" class="visuallyhidden">Password</label>                               
                                </div>
                                
                                <div class="form-field">                                
                                    <input type="checkbox" id="rememberMe_m" checked="checked"> <label for="rememberMe_m">Keep Me Signed In </label>
                                    <span class="remember_me help_me_link" onclick="alert('If you are the only one who uses your computer \nor if you are not concerned about keeping\nprivate information from the others who use \nyour computer (such as your spouse), you can \nselect the   &ldquo;Remember Me&rdquo; option on the &ldquo;Login&rdquo;.\n\nWith this option you can move freely in and out \nof the Zacks Investment Research site with all \nits parts, and each time you return, \nZacks Investment Research will automatically sign \nyou in.\n\nFor your security you should keep your \nZacks Investment Research Member Name and\nPassword in a safe place so that you can refer to\nthem when you need to.\n\nThe Zacks Investment Research Team')" >What does "Remember Me" do?</span>
                                </div>

                                <p><a href="/my-account/forgot.php?continue_to=%2F%2Fwww.zacks.com%2Fcommentary.php%3Farticle_id%3D1981366%26type%3Dblog" class="forgotPasswordLink">Don&#39;t Know Your Password?</a></p>
                                <p><input type="submit" value="Sign In" class="fancy_button green"></p>
                                
                                <button type="button" tabindex="0" aria-label="Close" role="button">
                                    <span id="mob_close_login">Close this window</span>
                                </button>

                            </form>
                        </div>
                        <!-- End: Login form -->
                    </li></ul>
</section>
<header class="primary-nav--content">
<nav id="primary" class="sticky" aria-label="main">
         <!-- nav toggle trigger for mobile -->
            <button class="toggle-navbar" type="button" data-toggle="collapse" aria-expanded="false" aria-controls="navbar-collapse" aria-label="Toggle header navigation">
            
                <span class="z1-mobile-menu">Menu</span>
            </button>            
            
            <ul id="navbar-collapse" class="navbar-collapse">
                <li class="" >
                    <a href="//www.zacks.com" aria-current="page">Home</a>
                    </li>
<li class="with-dd " >
                    <a href="//www.zacks.com/stocks.php" id="stocks-dd" class="mobile-disable">Stocks</a>
                    <!-- stocks dd -->
                    <button class="toggle-button sr-only sr-only-focusable" aria-expanded="false" aria-controls="stocks-menu">
                        <i class="fa fa-plus" aria-hidden="true"></i><i class="fa fa-caret-down" aria-hidden="true"></i>
                        <span class="sr-only">Stocks</span>
                    </button>
                    <ul class="menu" id="stocks-menu" aria-labelledby="stocks-dd">
                        <li ><a href="//www.zacks.com/stocks.php">Stocks</a></li>
<li ><a href="//www.zacks.com/stocks/buy-list/?adid=zp_topnav_1list">Zacks #1 Rank</a></li>
<li ><a href="//www.zacks.com/stocks/zacks-rank">Zacks Rank</a></li>
<li ><a href="//www.zacks.com/stocks/industry-rank/industries/">Zacks Industry Rank</a></li>
<li ><a href="//www.zacks.com/stocks/industry-rank/sectors/">Zacks Sector Rank</a></li>
<li ><a href="//www.zacks.com/stocks/equity-research">Equity Research</a></li>
<li ><a href="//www.zacks.com/stock-market-today">Markets</a></li>

                    </ul>
                </li>
<li class="with-dd " >
                    <a href="//www.zacks.com/funds/" id="funds-dd" class="mobile-disable">Funds</a>
                    <!-- stocks dd -->
                    <button class="toggle-button sr-only sr-only-focusable" aria-expanded="false" aria-controls="funds-menu">
                        <i class="fa fa-plus" aria-hidden="true"></i><i class="fa fa-caret-down" aria-hidden="true"></i>
                        <span class="sr-only">Funds</span>
                    </button>
                    <ul class="menu" id="funds-menu" aria-labelledby="funds-dd">
                        <li ><a href="//www.zacks.com/funds/">Funds</a></li>
<li ><a href="//www.zacks.com/funds/mutual-funds">Mutual Funds</a></li>
<li ><a href="//www.zacks.com/funds/etfs">ETFs</a></li>
<li ><a href="//www.zacks.com/screening/mutual-fund-screener">Mutual Fund Screener</a></li>
<li ><a href="//www.zacks.com/screening/etf-screener">ETF Screener</a></li>
<li ><a href="//www.zacks.com/funds/top-etfs">Top ETFs</a></li>

                    </ul>
                </li>
<li class="" >
                    <a href="//www.zacks.com/cryptocurrency" >Crypto</a>
                    </li>
<li class="with-dd " >
                    <a href="//www.zacks.com/earnings" id="earnings-dd" class="mobile-disable">Earnings</a>
                    <!-- stocks dd -->
                    <button class="toggle-button sr-only sr-only-focusable" aria-expanded="false" aria-controls="earnings-menu">
                        <i class="fa fa-plus" aria-hidden="true"></i><i class="fa fa-caret-down" aria-hidden="true"></i>
                        <span class="sr-only">Earnings</span>
                    </button>
                    <ul class="menu" id="earnings-menu" aria-labelledby="earnings-dd">
                        <li ><a href="//www.zacks.com/earnings">Earnings</a></li>
<li ><a href="//www.zacks.com/earnings/earnings-calendar">Earnings Calendar</a></li>
<li ><a href="//www.zacks.com/earnings/earnings-reports">Earnings Releases</a></li>
<li ><a href="//www.zacks.com/earnings/earnings-surprise-predictions/">Earnings ESP</a></li>
<li ><a href="//www.zacks.com/premium/esp-buy?adid=zp_topnav_espfilter">Earnings ESP Filter</a></li>

                    </ul>
                </li>
<li class="with-dd " >
                    <a href="//www.zacks.com/screening" id="screening-dd" class="mobile-disable">Screening</a>
                    <!-- stocks dd -->
                    <button class="toggle-button sr-only sr-only-focusable" aria-expanded="false" aria-controls="screening-menu">
                        <i class="fa fa-plus" aria-hidden="true"></i><i class="fa fa-caret-down" aria-hidden="true"></i>
                        <span class="sr-only">Screening</span>
                    </button>
                    <ul class="menu" id="screening-menu" aria-labelledby="screening-dd">
                        <li ><a href="//www.zacks.com/screening">Screening</a></li>
<li ><a href="//www.zacks.com/screening/stock-screener">Stock Screener</a></li>
<li ><a href="//www.zacks.com/screening/mutual-fund-screener">Mutual Fund Screener</a></li>
<li ><a href="//www.zacks.com/screening/etf-screener">ETF Screener</a></li>
<li ><a href="//www.zacks.com/screening/premium-screens">Premium Screens</a></li>
<li ><a href="//www.zacks.com/researchwizard/index.php?site=screen">Research Wizard</a></li>

                    </ul>
                </li>
<li class="with-dd " >
                    <a href="https://finance.zacks.com" id="finance-dd" class="mobile-disable">Finance</a>
                    <!-- stocks dd -->
                    <button class="toggle-button sr-only sr-only-focusable" aria-expanded="false" aria-controls="finance-menu">
                        <i class="fa fa-plus" aria-hidden="true"></i><i class="fa fa-caret-down" aria-hidden="true"></i>
                        <span class="sr-only">Finance</span>
                    </button>
                    <ul class="menu" id="finance-menu" aria-labelledby="finance-dd">
                        <li ><a href="https://finance.zacks.com">Personal Finance</a></li>
<li ><a href="https://finance.zacks.com/insurance/">Insurance</a></li>
<li ><a href="https://finance.zacks.com/investing/">Investing</a></li>
<li ><a href="https://finance.zacks.com/money-managing/">Money Managing</a></li>
<li ><a href="https://finance.zacks.com/real-estate/">Real Estate</a></li>
<li ><a href="https://finance.zacks.com/retirement-planning/">Retirement Planning</a></li>
<li ><a href="https://finance.zacks.com/tax-information/">Tax Information</a></li>

                    </ul>
                </li>
<li class="with-dd " >
                    <a href="//www.zacks.com/portfolios/my-stock-portfolio/" id="portfolio-dd" class="mobile-disable">Portfolio</a>
                    <!-- stocks dd -->
                    <button class="toggle-button sr-only sr-only-focusable" aria-expanded="false" aria-controls="portfolio-menu">
                        <i class="fa fa-plus" aria-hidden="true"></i><i class="fa fa-caret-down" aria-hidden="true"></i>
                        <span class="sr-only">Portfolio</span>
                    </button>
                    <ul class="menu" id="portfolio-menu" aria-labelledby="portfolio-dd">
                        <li ><a href="//www.zacks.com/portfolios/my-stock-portfolio/">My Portfolio</a></li>
<li ><a href="/portfolios/my-stock-portfolio?mode=create-new-portfolio">Create Portfolio</a></li>

                    </ul>
                </li>
<li class="with-dd " >
                    <a href="//www.zacks.com/education/stock-education" id="edu-dd" class="mobile-disable">Education</a>
                    <!-- stocks dd -->
                    <button class="toggle-button sr-only sr-only-focusable" aria-expanded="false" aria-controls="edu-menu">
                        <i class="fa fa-plus" aria-hidden="true"></i><i class="fa fa-caret-down" aria-hidden="true"></i>
                        <span class="sr-only">Education</span>
                    </button>
                    <ul class="menu" id="edu-menu" aria-labelledby="edu-dd">
                        <li ><a href="//www.zacks.com/education/stock-education">Education</a></li>
<li ><a href="//www.zacks.com/education/stock-education">Stocks</a></li>
<li ><a href="//www.zacks.com/style-scores-education/">Style Scores</a></li>
<li ><a href="//www.zacks.com/education/mutual-fund-education">Funds</a></li>
<li ><a href="//www.zacks.com/education/esp-education/">Earnings ESP</a></li>
<li ><a href="//www.zacks.com/education/screening-education">Screening</a></li>
<li ><a href="//www.zacks.com/reviews">Testimonials</a></li>
<li ><a href="//www.zacks.com/start-here">Zacks.com Tutorial</a></li>

                    </ul>
                </li>
<li class="" >
                    <a href="//www.zacks.com/financial-videos/index.php" >Video</a>
                    </li>
<li class="" >
                    <a href="//www.zacks.com/podcasts/" >Podcasts</a>
                    </li>
<li class="services-mm " >
                    <button class="toggle-button" id="services-dd" aria-expanded="false" aria-controls="services-menu">
                        Services
                        <i class="fa fa-plus" aria-hidden="true"></i>
                        <i class="fa fa-caret-down" aria-hidden="true"></i>
                        <span class="sr-only">Services</span>
                    </button>

                    <div id="services-menu" role="region" class="mega-menu" aria-labelledby="services-dd">
                        <!-- mega menu close btn -->
                        <button class="close-btn">
                            <i class="fa fa-times" aria-hidden="true"></i>
                            <span class="sr-only">Close Services menu</span>
                        </button>

                        <div class="col premium">
                            <a href="//www.zacks.com/investment-services/" class="heading" id="cat-1-title">Services Overview</a>
                            <ul aria-labelledby="cat-1-title">
                                <li><a href="//www.zacks.com/ultimate/?adid=TOP_ONLINE_NAV">Zacks Ultimate</a></li>
                                <li><a href="//www.zacks.com/investorcollection/">Zacks Investor Collection</a></li>
                                <li><a href="//www.zacks.com/premium.php">Zacks Premium</a></li>
                            </ul>
                        </div>

                        <div class="col">
<h2 class="heading" id="cat-2-title">Investor Services</h2>
<ul aria-labelledby="cat-2-title">
<li><a href="//www.zacks.com/etfinvestor/" >ETF Investor</a></li>
<li><a href="//www.zacks.com/homerun/?adid=TOP_ONLINE_NAV" >Home Run Investor</a></li>
<li><a href="//www.zacks.com/incomeinvestor/" >Income Investor</a></li>
<li><a href="//www.zacks.com/stocksunder10/" >Stocks Under $10</a></li>
<li><a href="//www.zacks.com/valueinvestor/?adid=TOP_ONLINE_NAV" >Value Investor</a></li>
<li><a href="//www.zacks.com/top-10-stocks.php" >Top 10 Stocks</a></li>
</ul>
<h2 class="heading" id="cat-3-title">Other Services</h2>
<ul aria-labelledby="cat-3-title">
<li><a href="//www.zacks.com/registration/zmt/welcome/eoffer/33e3/?adid=TOP_ONLINE_NAV" >Method for Trading</a></li>
<li><a href="//www.zacks.com/registration/rw/welcome/eoffer/3dd7/?adid=TOP_ONLINE_NAV" >Research Wizard</a></li>
<li><a href="//www.zacks.com/confidential/?adid=TOP_ONLINE_NAV" >Zacks Confidential</a></li>
</ul>
</div>
<div class="col">
<h2 class="heading" id="cat-4-title">Trading Services</h2>
<ul aria-labelledby="cat-4-title">
<li><a href="//www.zacks.com/blackboxtrader/" >Black Box Trader</a></li>
<li><a href="//www.zacks.com/counterstrike/" >Counterstrike</a></li>
<li><a href="//www.zacks.com/headlinetrader/" >Headline Trader</a></li>
<li><a href="//www.zacks.com/insidertrader/" >Insider Trader</a></li>
<li><a href="//www.zacks.com/largecaptrader/" >Large-Cap Trader</a></li>
<li><a href="//www.zacks.com/optionstrader/" >Options Trader</a></li>
<li><a href="//www.zacks.com/shortlist/" >Short Sell List</a></li>
<li><a href="//www.zacks.com/surprisetrader/" >Surprise Trader</a></li>
<li><a href="//www.zacks.com/tazr/" >TAZR</a></li>
</ul>
<h2 class="heading" id="cat-5-title">Innovators</h2>
<ul aria-labelledby="cat-5-title">
<li><a href="//www.zacks.com/blockchaininnovators/" >Blockchain</a></li>
<li><a href="//www.zacks.com/commodityinnovators/" >Commodity</a></li>
<li><a href="//www.zacks.com/healthcareinnovators/" >Healthcare</a></li>
<li><a href="//www.zacks.com/marijuanainnovators/" >Marijuana</a></li>
<li><a href="//www.zacks.com/technologyinnovators/" >Technology</a></li>
</ul>
</div>

                    </div>
                </li>

                
                <!-- search container -->
                 <li class="search-container ">
                     <form id="search_form" name="frmsearch" method="post" action="/search.php" autocomplete="off">
                     <label id="header_search" for="search-q" class="sr-only">Quote or Search</label>
                         <input type="search" id="search-q" name="search-q" class="dropdown " value="" hasdefault="false" searchextras="all" placeholder="Quote or Search" autofocus="autofocus" aria-autocomplete="both" aria-controls="result_list_view" aria-haspopup="listbox" aria-expanded="false"/>
                         <button type="submit">
                             <i class="fa fa-search" aria-hidden="true"></i>
                             <span class="sr-only">Search</span>
                         </button>
                         <input type="hidden" class="search_mode" name="search_mode" value="" />
                         <input type="hidden" class="ticker_type" name="ticker_type" value="" />
                         <div id="result_list_view" class="result_container">
                    <div class="results_tickers"></div>
                </div>
                     </form>
                     <script>document.getElementById('search-q').setAttribute("autocomplete", "off");</script>
                 </li>
                
                
            </ul>
</nav>
<p class="top_special"><a href="https://www.zacks.com/start-here?icid=home-home-startHere-pfp-text_ribbon-tx_06" title="Get Started With Zacks"><span>New to Zacks?</span> Get started here.</a></p>
<ul id="user_menu" aria-label="My Account">
        <li><a href="https://www.zacks.com/registration_info.php">Join Now</a></li>
                    <li id="log_me_in">
                        <a href="#" aria-controls="log_me_in" aria-expanded="false" class="signin_expand">Sign In</a>
                        <!-- Begin: Login form -->
                        <div id="login_form" role="form" aria-label="Login">
                            <form name="jslogin_form" class="jslogin_form" method="post" action="https://www.zacks.com/stock/news/1981366/is-most-watched-stock-target-hospitality-corp-th-worth-betting-on-now?" onsubmit="return JSloginCheck(this);">
                            <input type="hidden" name="force_login" value="true" class="hidden">
                            
                                <h2>Member Sign In</h2>
                                
                                <div class="form-field float-label">
                                    
                                    <input id="username" type="text" name="username" placeholder="Username or Email Address" required>
                                    <label for="username">Username or Email Address</label>
                                </div>
                                
                                <div class="form-field float-label"> 
                                    <input id="password" type="password" name="password" placeholder="Password" required> 
                                    <label for="password">Password</label>                               
                                </div>
                                
                                <div class="form-field">
                                    <input type="checkbox" id="rememberMe" name="remember_me" checked="checked" role="checkbox"> <label for="rememberMe">Keep Me Signed In </label>
                                    <span class="remember_me help_me_link" onclick="alert('If you are the only one who uses your computer \nor if you are not concerned about keeping\nprivate information from the others who use \nyour computer (such as your spouse), you can \nselect the   &ldquo;Remember Me&rdquo; option on the &ldquo;Login&rdquo;.\n\nWith this option you can move freely in and out \nof the Zacks Investment Research site with all \nits parts, and each time you return, \nZacks Investment Research will automatically sign \nyou in.\n\nFor your security you should keep your \nZacks Investment Research Member Name and\nPassword in a safe place so that you can refer to\nthem when you need to.\n\nThe Zacks Investment Research Team')" >What does "Remember Me" do?</span>
                                </div>

								<p><a href="/my-account/forgot.php?continue_to=%2F%2Fwww.zacks.com%2Fcommentary.php%3Farticle_id%3D1981366%26type%3Dblog" class="forgotPasswordLink" role="link">Don&#39;t Know Your Password?</a></p>

                                <p><input type="submit" value="Sign In" class="fancy_button green" role="button"></p>
                                
                                <button type="button" tabindex="0" aria-label="Close" role="button" id="close_login">
                                    <span class="sr-only">Close this window</span>
                                </button>
                            </form>
                        </div>
                        <!-- End: Login form -->
                    </li>
                    <li><a href="https://www.zacks.com/help/">Help</a></li>
    </ul>
</header>    <!-- Begin: Header Ad -->
    <div role="banner" id="banner">
        <a href="/" role="link" rel="home">
            <img src="https://staticx.zacks.com/images/zacks/logos/logo2014_tagstack-sitehead_232x92_2x.png" width="232" height="92" alt="Zacks Investment Research Home" title="" />
        </a>

        <!-- nav toggle button for mobile menu -->
        <div class="nav-toggle">
            <span></span>
            <span></span>
            <span></span>
        </div>
        <!-- nav toggle button for mobile menu --><div align="center" data-freestar-ad="__728x90" id="zacks_leaderboard_atf" class="dfp_ad_unit">
    <script data-cfasync="false" type="text/javascript">    
    if( typeof(freestar) != 'undefined' ) {
        freestar.config.enabled_slots.push({ placementName: "zacks_leaderboard_atf", slotId: "zacks_leaderboard_atf" });
    } else {
        console.log('freestar not initialized!');
    }

    </script>
</div>    </div>
    <!-- End: Header Ad -->
<div class="hide" id="gateway_modal_offsite">
<p>You are being directed to ZacksTrade, a division of LBMZ Securities and licensed broker-dealer. ZacksTrade and Zacks.com are separate companies. The web link between the two companies is not a solicitation or offer to invest in a particular security or type of security. ZacksTrade does not endorse or adopt any particular investment strategy, any analyst opinion/rating/report or any approach to evaluating indiv idual securities.</p>

<p>If you wish to go to ZacksTrade, click <strong>OK</strong>. If you do not, click Cancel.</p>

<p class="zt_offsite_button"><a class="fancy_button green" href="https://www.zackstrade.com/2019-1-dollar" id="gateway_offsite_link">OK</a> <a class="fancy_button deactive" href="#">Cancel</a></p>
</div>
<!--MSG:11843--><!-- z2_top_nav end -->

<!-- End: top_navigation-->

<!-- Begin: Main Content -->
<div id="main_content" role="main">

<!-- Begin: toolbar-->
<!-- z2_toolbar start -->
<div id="toolbar">
    <span>Back to top</span>
</div>

<!-- z2_toolbar end -->

<!-- End: toolbar-->

    <div class="main_body">

<!-- Begin: centerCol -->
<!-- z2_commentary_using_view start -->
    <section id="commentary_article" class="commentary_b">
        <script>
            auto_ad = -1;
            article_id = 1981366;
        </script>
        <!--<script defer src="https://staticx.zacks.com/js/zacks/inline/commentary.js"></script>-->
        <script defer src="https://staticx.zacks.com/js/zacks/inline/article_cta.js"></script>
        <script>
        var articleCta = articleCta || {};
        articleCta.articleId   = '1981366';
        articleCta.datePosted  = '091622';
        articleCta.articleType = 'BLOG';        
        </script>
        <div class="article_banner">
            <img src="https://staticx.zacks.com/images/icons/general/trans.png" ll_src="https://staticx-tuner.zacks.com/images/default_article_images/default0.jpg" alt="" title="">
             <p>Image: Bigstock</p>            
        </div>
        <article>
         <h1>Is Most-Watched Stock Target Hospitality Corp. (TH) Worth Betting on Now?</h1>
            <header class="ticker-and-social-ribbon">
              <aside>
                 <p class="byline">Zacks Equity Research
                    <span><time datetime="00:00">September 16, 2022</time></span>
                </p>
                 <p class="hoverquote_block"><button class="modal_external appear-on-focus" href="/modals/quick-quote.php" rel="TH">TH Quick Quote</button><a href="/stock/quote/TH" class="hoverquote-container-od analytics_tracking hoverquote-neg" rel="TH" show-add-portfolio="true" id = ticker_social_ribbon-TH-txt 
><span class="hoverquote-symbol">TH</span></a>    </p>
                 <style type="text/css">#ztBtn2 .valign {
        display:inline-block;
        vertical-align:top;
        position:relative;
        color: #fff;
        }
        #ztBtn2 .valign:hover{
            color: #fff !important;
        }
    #ztBtn2 {
        height:24px;
        padding:3px 10px 5px;
        display: inline-block;
        background:#2b2b2b;
        background-size:cover;
        border: 1px solid #2b2b2b;
        -webkit-border-radius: 3px;
        -moz-border-radius: 6px; -o-border-radius: 6px; border-radius:6px;
        margin:0 0 16px;
        font-family: 'Lucida Grande', 'Lucida Sans Unicode', 'Lucida Sans', Verdana, 'Droid Sans', Roboto, Helvetica, Arial, sans-serif;
        font-size:16px;
        line-height:1;
        text-decoration:none;
        color:#fff;
        text-align:center;
        top: -7px !important;
        cursor: pointer;
        }
        
    #ztBtn2 #icon {
        top:0;
        border:none;
        outline:none;
        }
        
    #ztBtn2 #price {
        background: #3aa150;
        color: #fff;
        padding: 6px;
        border-radius: 50%;
        font-size: 22px;
        line-height: 1;
        border: solid 1px #207132;
        font-weight: bold;
        box-shadow: 0px 0px 1px #000;
        text-shadow: 0px 1px 1px rgba(0,0,0,0.6);
        bottom: 5px;
        }
        
    #ztBtn2 #symbol {
        font-size:16px;
        line-height:1;
        position:relative;
        bottom:5px;
        margin-right:-2px;
        font-weight:normal;
        }
        
        @media screen and (max-width: 1023px){
            #ztBtn2{top: 21px !important;}
        }
</style>
<p><a class="zt_offsite_link btn-zt" id="ztBtn2" tracking_code="13418215"><img border="0" class="valign" height="20" id="icon" src="https://staticx-tuner.zacks.com/woas/adv/ztrade/ztNow_icon2.png" width="23" /> <span class="valign" style="top:4px; font-size: 12pt;">Trades from</span> <span class="valign" id="price"><span id="symbol">$</span>1</span> </a></p>
<!--MSG:16163, content.zacks.com, bottom STAGE/PRODUCTION textarea -->
                
                <div>  
              <div class="social_plugins">
                <div class="social_icons_left">
                <script>var switchTo5x=true;</script>
                <script async src="//ws.sharethis.com/button/buttons.js"></script>
                
                <span class='st_facebook_large' displayText='Facebook' st_url='https://www.zacks.com/stock/news/1981366/is-most-watched-stock-target-hospitality-corp-th-worth-betting-on-now?cid=SM-facebook-HL-1981366'></span>
                <span class='st_twitter_large' displayText='Tweet' st_url='https://www.zacks.com/stock/news/1981366/is-most-watched-stock-target-hospitality-corp-th-worth-betting-on-now?cid=SM-twitter-HL-1981366'></span>
                <span class='st_linkedin_large' displayText='LinkedIn' st_url='https://www.zacks.com/stock/news/1981366/is-most-watched-stock-target-hospitality-corp-th-worth-betting-on-now?cid=SM-linkedin-HL-1981366'></span>
                <span class='st_pinterest_large' displayText='Pinterest' st_url='https://www.zacks.com/stock/news/1981366/is-most-watched-stock-target-hospitality-corp-th-worth-betting-on-now?cid=SM-pinterest-HL-1981366'></span>
                <span class='st_email_large' displayText='Email' st_url='https://www.zacks.com/stock/news/1981366/is-most-watched-stock-target-hospitality-corp-th-worth-betting-on-now?cid=SM-email-HL-1981366'></span>
            </div>                        <div class="social_icons_right">
                            <a href="https://api.stocktwits.com/widgets/share" id="stocktwits-share-button-view" class="stocktwits-button" data-article-id=1981366><img src="https://staticx.zacks.com/images/zacks/icons/st_icon.png" alt="Share on StockTwits"/></a>
                            <script async src="https://api.stocktwits.com/addon/button/share.min.js"></script>
                        </div>
                    </div>
                </div>
                <!-- edit follow section-->
            <div class="edit_follow_section">            
            <p id="category_part" style="display:none">                
                <span>You follow Tale of the Tape - <a class="call_action" href="/my-account/alert-preferences/">edit</a></span>
            </p>
            <p id="author_part" style="display:none">                
                <span>You follow Zacks Equity Research - <a class="call_action" href="/my-account/alert-preferences/">edit</a></span>
            </p> 
            </div>
        <!-- follow author modal-->
            <div id="follow_author_toggle" class="author_modal">
            <h4>What would you like to follow?</h4>
                <div class="container">
                <input type="hidden" name="is_follow_category" id="is_follow_category" value="" />
                <input type="hidden" name="is_follow_author" id="is_follow_author" value="N" />
                
                <p id="author_follow_button" style="display:none">
                <input type="checkbox" name="modal_author_name" id="modal_author_name" value="631459560">
                <label for="modal_author_name">Zacks Equity Research</label>
                </p>                
                <p id="category_follow_button" style="display:none">
                <input type="checkbox" name="modal_article_category" id="modal_article_category" value="571">
                <label for="modal_article_category">Tale of the Tape</label>
                </p>
                
                <div class="buttons">
                  <a id="follow_action" class="modal_external" href="/modals/follow-author.php?author_id=NULL&category_id=NULL" title="">
                  <img class="small_follow_btn" src="https://staticx.zacks.com/images/zacks/icons/mobile_follow_btn.png" alt="Follow Author" title="">
                  </a>
                  <a class="call_action" onclick="document.getElementById('follow_author_toggle').style.display='none'" class="cancel">Cancel</a>
                  </div>
              </div>
            </div>
            </aside>
        </header>
    </article>            <article>
                <div class="archive_collapse"><span class="show_article">Read More</span><span class="hide_article">Hide Full Article</span></div>
                <div class="commentary_body">
                    
                                        <div id="inline_top">
                        <div id="Inline-Top_402" class="dfp_ad_unit"></div>
                    </div>                  
                    <div id="comtext">
                        <p><b>Target Hospitality</b> (<button class="modal_external appear-on-focus" href="/modals/quick-quote.php" rel="TH">TH Quick Quote</button><a href="/stock/quote/TH" class="hoverquote-container-od analytics_tracking hoverquote-neg" rel="TH" show-add-portfolio="true" id = commentary_body-TH-txt 
 style="font-weight:bold;"><span class="hoverquote-symbol">TH</span></a> <span> - </span> <a class="in_copy newwin" href="/registration/premium/login/?ALERT=zrmodule&mode=zrmodule&t=TH&ADID=ZCOM_ARTICLEBODY_TCK&icid=BLOG-Tale_of_the_Tape|Most_Searched_Stocks_-_V1-1981366-free_report-commentary_body-TH" alt="Free Report" title="Free Report">Free Report</a>)     has been one of the most searched-for stocks on Zacks.com lately. So, you might want to look at some of the facts that could shape the stock's performance in the near term.</p><p>Over the past month, shares of this company have returned -0.3%, compared to the Zacks S&amp;P 500 composite's -9.1% change. During this period, the Zacks Leisure and Recreation Services industry, which Target Hospitality falls in, has lost 4.7%. The key question now is: What could be the stock's future direction?</p><p>While media releases or rumors about a substantial change in a company's business prospects usually make its stock 'trending' and lead to an immediate price change, there are always some fundamental facts that eventually dominate the buy-and-hold decision-making.</p><p><b>Earnings Estimate Revisions</b></p><p>Here at Zacks, we prioritize appraising the change in the projection of a company's future earnings over anything else. That's because we believe the present value of its future stream of earnings is what determines the fair value for its stock.</p><p>Our analysis is essentially based on how sell-side analysts covering the stock are revising their earnings estimates to take the latest business trends into account. When earnings estimates for a company go up, the fair value for its stock goes up as well. And when a stock's fair value is higher than its current market price, investors tend to buy the stock, resulting in its price moving upward. Because of this, empirical studies indicate a strong correlation between trends in earnings estimate revisions and short-term stock price movements.</p><p>For the current quarter, Target Hospitality is expected to post earnings of $0.55 per share, indicating a change of +685.7% from the year-ago quarter. The Zacks Consensus Estimate remained unchanged over the last 30 days.</p><p>For the current fiscal year, the consensus earnings estimate of $1.37 points to a change of +2,840% from the prior year. Over the last 30 days, this estimate has remained unchanged.</p><p>For the next fiscal year, the consensus earnings estimate of $1.98 indicates a change of +44.3% from what Target Hospitality is expected to report a year ago. Over the past month, the estimate has remained unchanged.</p><p>With an impressive <a href="https://www.zacks.com/performance_disclosure" target="_blank">externally audited track record</a>, our proprietary stock rating tool -- the Zacks Rank -- is a more conclusive indicator of a stock's near-term price performance, as it effectively harnesses the power of earnings estimate revisions. The size of the recent change in the consensus estimate, along with three other <a href="https://www.zacks.com/education/stock-education/zacks-rank-guide-9" target="_blank">factors related to earnings estimates</a>, has resulted in a Zacks Rank #2 (Buy) for Target Hospitality.</p><p>The chart below shows the evolution of the company's forward 12-month consensus EPS estimate:</p><p><b>12 Month EPS</b></p><p><img src="https://chart-service.zacks.com/images/weekly/yesop_12_month_eps/TH.png" alt="12-month consensus EPS estimate for TH _12MonthEPSChartUrl" title="" class="chart"></p><p><b>Revenue Growth Forecast</b></p><p>Even though a company's earnings growth is arguably the best indicator of its financial health, nothing much happens if it cannot raise its revenues. It's almost impossible for a company to grow its earnings without growing its revenue for long periods. Therefore, knowing a company's potential revenue growth is crucial.</p><p>In the case of Target Hospitality, the consensus sales estimate of $158.2 million for the current quarter points to a year-over-year change of +77.4%. The $509.8 million and $615.8 million estimates for the current and next fiscal years indicate changes of +75% and +20.8%, respectively.</p><p><b>Last Reported Results and Surprise History</b></p><p>Target Hospitality reported revenues of $109.65 million in the last reported quarter, representing a year-over-year change of +46.2%. EPS of $0.24 for the same period compares with -$0.01 a year ago.</p><p>Compared to the Zacks Consensus Estimate of $104.6 million, the reported revenues represent a surprise of +4.83%. The EPS surprise was +41.18%.</p><p>Over the last four quarters, Target Hospitality surpassed consensus EPS estimates three times. The company topped consensus revenue estimates each time over this period.</p><p><b>Valuation</b></p><p>Without considering a stock's valuation, no investment decision can be efficient. In predicting a stock's future price performance, it's crucial to determine whether its current price correctly reflects the intrinsic value of the underlying business and the company's growth prospects.</p><p>While comparing the current values of a company's valuation multiples, such as price-to-earnings (P/E), price-to-sales (P/S) and price-to-cash flow (P/CF), with its own historical values helps determine whether its stock is fairly valued, overvalued, or undervalued, comparing the company relative to its peers on these parameters gives a good sense of the reasonability of the stock's price.</p><p>As part of the Zacks Style Scores system, the Zacks Value Style Score (which evaluates both traditional and unconventional valuation metrics) organizes stocks into five groups ranging from A to F (A is better than B; B is better than C; and so on), making it helpful in identifying whether a stock is overvalued, rightly valued, or temporarily undervalued.</p><p>Target Hospitality is graded B on this front, indicating that it is trading at a discount to its peers. <a href="https://www.zacks.com/stock/research/TH/stock-style-scores" target="_blank">Click here </a> to see the values of some of the valuation metrics that have driven this grade.</p><p><b>Bottom Line</b></p><p>The facts discussed here and much other information on Zacks.com might help determine whether or not it's worthwhile paying attention to the market buzz about Target Hospitality. However, its Zacks Rank #2 does suggest that it may outperform the broader market in the near term.</p><div class="cta_section"></div>
                    </div>
                                        <div id="inline_bottom">
                        <div id="Inline-Bottom_403" class="dfp_ad_unit"></div>
                    </div>
                </div>
            </article>
        </section>        <section class="commentary_reports_content commentary_b">
            <div class="commentary_reports">
                <div class="commentary_reports_block">
                    <br><div class="reports_header"><h1>In-Depth Zacks Research for the Tickers Above</h1><br></div>
                    <div class="reports_header"><h3>Normally $25 each - click below to receive one report FREE:</h3><br></div>
                    <p class="report_camera_text"><a href="/registration/premium/login/?ALERT=zrmodule&mode=zrmodule&t=TH&ADID=ZCOM_ARTICLEBTM_TCK_571&icid=BLOG-Tale_of_the_Tape|Most_Searched_Stocks_-_V1-1981366-free_report-commentary_reports-text-TH" class="comm_button newwin"><span>Target Hospitality Corp. (TH) - free report &gt;&gt;</span></a></p>
                </div>
            </div>
        </section>
<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "BreadcrumbList",
  "itemListElement": [
    {
      "@type": "ListItem",
      "position": 1,
      "item": {
        "@id": "https://www.zacks.com/stock/quote/TH",
        "name": "Target Hospitality Corp. : (TH)"
      }
    }, {
      "@type": "ListItem",
      "position": 2,
      "item": {
        "@id": "https://www.zacks.com/stock/news/1981366/is-most-watched-stock-target-hospitality-corp-th-worth-betting-on-now",
        "name": "Is Most-Watched Stock Target Hospitality Corp. (TH) Worth Betting on Now?"
      }
    }
  ]
}
</script>
<!-- z2_commentary_using_view end -->

<!-- z2_more_from_zacks_category start -->
<section id="z2_more_from_zacks_category" class="commentary_zacks_news commentary_grid_container"></section>
<script defer src="https://staticx.zacks.com/js/zacks/inline/more_from_zacks.js"></script>    
<script>
var articleType     = 'B';
var typeId          = 49;
var categoryName    = 'Tale of the Tape';
var categoryId      = 0;
var authorName      = 'Zacks Equity Research';
var orgAuthorName   = 'Zacks Equity Research';
var subCategoryName = 'Tale of the Tape : Most Searched Stocks - V1';
var datePosted      = 'September 16, 2022';
var tickerList      = 'TH';
</script><!-- z2_more_from_zacks_category end -->

<!-- z2_you_may_like start -->
    <section id="youmay_like_container" class="commentary_zacks_news commentary_grid_container you_may_like"></section>
    <script defer src="https://staticx.zacks.com/js/zacks/inline/you_may_like.js"></script>    

<!-- z2_you_may_like end -->

<!-- z2_published_in start -->
<section id="" class="">
    <h1>Published in</h1> <a href="/topics/growth-investors" title="growth-investors" class="text_capitalize article_tag" >growth-investors</a> <a href="/topics/popular-stocks" title="popular-stocks" class="text_capitalize article_tag" >popular-stocks</a> <a href="/topics/trending-stocks" title="trending-stocks" class="text_capitalize article_tag" >trending-stocks</a>
</section><!-- z2_published_in end -->

<!-- z2_video_player start -->
<!-- z2_video_player end -->

<!-- End: centerCol -->

    </div> <!-- End: Main Body -->

    <aside id="third_rail">
<!-- Begin: rightCol -->
<!-- right_panel start -->

                                <!-- In Your face Start -->
                                <div id="featured_zacks_rank_stocks">
                                    <div id="slider">
                                        <!-- Commentary IYF Module B - #671 -->
<style>
    #commentary-module {padding:8px 10px; border:solid 1px #717171; border-radius:6px; background:#fff;}
    #commentary-module .headline {padding-bottom:3px; border-bottom:solid 3px #000; margin-bottom:10px; color: #000; font-size:12pt;}
    #commentary-module .textbox {width:242px; padding:10px; margin-bottom:10px; border:solid 1px #cacaca; border-radius:3px; box-shadow:inset 0 1px 2px rgba(0,0,0,0.4);}
    #commentary-module .input_button {padding:12px; border:solid 1px #bd4600; border-radius:3px; box-shadow:0 1px 4px rgba(0,0,0,.5), inset 1px 1px 3px rgba(255,255,255,.5); font-size:10.5pt;  text-shadow:0 -1px 2px #000; 
        background: #dc0000; background: linear-gradient(to bottom,#dc0000 0,#dc0000 50%,#dc0000 70%,#dc0000 100%); filter: progid:DXImageTransform.Microsoft.gradient(startColorstr='#dc0000',endColorstr='#dc0000',GradientType=0); color:#fff; font-weight:bold; cursor: pointer;
    }
    #commentary-module footer p, #commentary-module footer p a {font-size:10px;}
</style>
<section id="commentary-module">
    <h1 class="headline">Zacks' 7 Best<br />Strong Buy Stocks for September, 2022</h1>
    <p>Our experts picked 7 Zacks Rank #1 Strong Buy stocks with the best chance to skyrocket within the next 30-90 days.</p>
    <p>Recent stocks from this report have soared up to +178.7% in 3 months - this month's picks could be even better. See our report's 7 new picks today, absolutely FREE.</p>
    <form action="/registration/pfp/step2.php" id="iyfModuleForm" method="post" name="pfp-commentary-form" onsubmit="return false;">
        <input type="text" name="email" id="email" class="textbox" maxlength="200" placeholder="Enter your best email address" onfocus="this.placeholder=''" onblur="this.placeholder='Enter your best email address'" />
        <input name="ADID" type="hidden" value="ZCOM_IYF_COMM_7BEST_TITLE" /> 
        <input name="ALERT" type="hidden" value="IYF_COMM_671_A384" /> 
        <button class="input_button submit" id="button">&#9656; See 7 Strong Buy Stocks Free</button>
    </form>
    <footer id="footer">
        <p><a class="call_to_action newwin" href="/privacy.php">Privacy Policy</a> <span aria-hidden="true"> | </span> No cost, no obligation to buy anything ever.</p>
    </footer>
</section>
<script src="https://staticx-tuner.zacks.com/woas/adv/services/js/email-validation-iyf-module-1.0.3.js"></script>
<script>apply_validate_email_submit('submit');</script>
                                    </div>
                                </div>
<script defer src="https://staticx.zacks.com/js/zacks/inline/inyourface_mini.js"></script>
                                <!-- In Your face End -->
                    <div align="center" data-freestar-ad="__300x600" id="zacks_medrec_top" class="dfp_ad_unit">
    <script data-cfasync="false" type="text/javascript">    
    if( typeof(freestar) != 'undefined' ) {
        freestar.config.enabled_slots.push({ placementName: "zacks_medrec_top", slotId: "zacks_medrec_top" });
    } else {
        console.log('freestar not initialized!');
    }

    </script>
</div>
<!-- Display this section only if data is being provided -->
 
<div class="next_news content_block"> 
    <!-- Begin: Next news -->
    <h1 class="side_bar_header">Up Next</h1>
    <div class="next_media content_block">
        <a href="/stock/news/1981365/is-most-watched-stock-alphabet-inc-goog-worth-betting-on-now?art_rec=blog-tale_of_the_tape-up_next-ID01-img-1981365">
            <img src="https://staticx.zacks.com/images/icons/general/trans.png" ll_src="https://staticx-tuner.zacks.com/images/default_article_images/default312.jpg" alt="" title=""></a>
            <a href="/stock/news/1981365/is-most-watched-stock-alphabet-inc-goog-worth-betting-on-now?art_rec=blog-tale_of_the_tape-up_next-ID01-txt-1981365"><h2 class="side_bar_article_link">Is Most-Watched Stock Alphabet Inc. (GOOG) Worth Betting on Now?</h2>
        </a>
    </div>
</div>
                    <div align="center" data-freestar-ad="__300x600" id="zacks_medrec_mid" class="dfp_ad_unit">
    <script data-cfasync="false" type="text/javascript">    
    if( typeof(freestar) != 'undefined' ) {
        freestar.config.enabled_slots.push({ placementName: "zacks_medrec_mid", slotId: "zacks_medrec_mid" });
    } else {
        console.log('freestar not initialized!');
    }

    </script>
</div>    <div class="read_articles content_block"> 
        <!-- Begin: Read article section -->
        <h1 class="side_bar_header">Most Read</h1>
        <div id="slider_wrapper">
            <div class="swiper-container_mostread swiper-container-horizontal">
                <div class="swiper-wrapper">
                    <div class="swiper-slide swiper-slide-active" style="margin-right: 18px;">
                                <article>
                                    <header class="article_track">
											   <div class="article_img"> <a href="https://www.zacks.com/commentary/1981615/park-your-cash-in-this-market-beating-dividend-paying-industry" class="analytics_tracking" id="most_read-1981615-img"><img src="https://staticx.zacks.com/images/icons/general/trans.png" ll_src="https://staticx-tuner.zacks.com/images/articles/specialcoverage/df/28253.jpg" title="Park Your Cash in This Market-Beating, Dividend-Paying Industry"  alt="Park Your Cash in This Market-Beating, Dividend-Paying Industry" width="100" height="60"></a></div>
												<h1 class="most_read_article teaser truncated_text_three"><div><a href="https://www.zacks.com/commentary/1981615/park-your-cash-in-this-market-beating-dividend-paying-industry" id="most_read-1981615-txt">Park Your Cash in This Market-Beating, Dividend-Paying Industry</a></div></h1>
											   
									</header>
                                 </article>									
							</div><div class="swiper-slide swiper-slide-active" style="margin-right: 18px;">
                                <article>
                                    <header class="article_track">
											   <div class="article_img"> <a href="https://www.zacks.com/commentary/1981090/3-mega-cap-stocks-with-unbelievably-strong-free-cash-flow" class="analytics_tracking" id="most_read-1981090-img"><img src="https://staticx.zacks.com/images/icons/general/trans.png" ll_src="https://staticx-tuner.zacks.com/images/articles/specialcoverage/01/2893.jpg" title="3 Mega-Cap Stocks With Unbelievably Strong Free Cash Flow"  alt="3 Mega-Cap Stocks With Unbelievably Strong Free Cash Flow" width="100" height="60"></a></div>
												<h1 class="most_read_article teaser truncated_text_three"><div><a href="https://www.zacks.com/commentary/1981090/3-mega-cap-stocks-with-unbelievably-strong-free-cash-flow" id="most_read-1981090-txt">3 Mega-Cap Stocks With Unbelievably Strong Free Cash Flow</a></div></h1>
											   
									</header>
                                 </article>									
							</div><div class="swiper-slide swiper-slide-active" style="margin-right: 18px;">
                                <article>
                                    <header class="article_track">
											   <div class="article_img"> <a href="https://www.zacks.com/commentary/1980765/new-strong-buy-stocks-for-september-16th" class="analytics_tracking" id="most_read-1980765-img"><img src="https://staticx.zacks.com/images/icons/general/trans.png" ll_src="https://staticx-tuner.zacks.com/images/articles/specialcoverage/5b/2246.jpg" title="New Strong Buy Stocks for September 16th"  alt="New Strong Buy Stocks for September 16th" width="100" height="60"></a></div>
												<h1 class="most_read_article teaser truncated_text_three"><div><a href="https://www.zacks.com/commentary/1980765/new-strong-buy-stocks-for-september-16th" id="most_read-1980765-txt">New Strong Buy Stocks for September 16th</a></div></h1>
											   
									</header>
                                 </article>									
							</div><div class="swiper-slide swiper-slide-active" style="margin-right: 18px;">
                                <article>
                                    <header class="article_track">
											   <div class="article_img"> <a href="https://www.zacks.com/stock/news/1981480/3-blue-chip-communication-stocks-to-profit-from-the-dip" class="analytics_tracking" id="most_read-1981480-img"><img src="https://staticx.zacks.com/images/icons/general/trans.png" ll_src="https://staticx-tuner.zacks.com/images/articles/specialcoverage/3f/2618.jpg" title="3 Blue-Chip Communication Stocks to Profit From the Dip"  alt="3 Blue-Chip Communication Stocks to Profit From the Dip" width="100" height="60"></a></div>
												<h1 class="most_read_article teaser truncated_text_three"><div><a href="https://www.zacks.com/stock/news/1981480/3-blue-chip-communication-stocks-to-profit-from-the-dip" id="most_read-1981480-txt">3 Blue-Chip Communication Stocks to Profit From the Dip</a></div></h1>
											   
									</header>
                                 </article>									
							</div><div class="swiper-slide swiper-slide-active" style="margin-right: 18px;">
                                <article>
                                    <header class="article_track">
											   <div class="article_img"> <a href="https://www.zacks.com/stock/news/1981483/snowflake-trading-continues-and-its-still-summer" class="analytics_tracking" id="most_read-1981483-img"><img src="https://staticx.zacks.com/images/icons/general/trans.png" ll_src="https://staticx-tuner.zacks.com/images/articles/specialcoverage/55/28241.jpg" title="AWS 9/16: "Snowflake" Trading Continues, and It's Still Summer"  alt="AWS 9/16: "Snowflake" Trading Continues, and It's Still Summer" width="100" height="60"></a></div>
												<h1 class="most_read_article teaser truncated_text_three"><div><a href="https://www.zacks.com/stock/news/1981483/snowflake-trading-continues-and-its-still-summer" id="most_read-1981483-txt">AWS 9/16: "Snowflake" Trading Continues, and It's Still Summer</a></div></h1>
											   
									</header>
                                 </article>									
							</div>
                </div>	 
                <!-- Add Pagination -->
                <div class="swiper-pagination"></div>
                <!-- Add Arrows -->
                <div class="swiper-button-next" id="swiper-mostread-button-next">&rsaquo;</div>
                <div class="swiper-button-prev swiper-button-disabled" id="swiper-mostread-button-prev">&lsaquo;</div>
            </div>
        </div>	 
    </div>                    <div align="center" data-freestar-ad="__300x250" id="zacks_medrec_bottom" class="dfp_ad_unit">
    <script data-cfasync="false" type="text/javascript">    
    if( typeof(freestar) != 'undefined' ) {
        freestar.config.enabled_slots.push({ placementName: "zacks_medrec_bottom", slotId: "zacks_medrec_bottom" });
    } else {
        console.log('freestar not initialized!');
    }

    </script>
</div><!-- right_panel end -->

<!-- End: rightCol -->
    </aside>
<!-- Begin: Bottom Ad -->
<!-- Begin: partnerDart -->
<!-- z2_banner_bottom start -->
<!-- z2_banner_bottom end -->

<!-- End: partnerDart -->
<!-- End: Bottom Ad -->
</div> <!-- End: Main Content -->

<footer>
<!-- Begin: Footer -->
<!-- z2_footer start -->
<div id="quick_links">
<section>
<h2>Quick Links</h2>
<!-- nav toggle button for mobile menu -->

<div class="quicklink-toggle"><small>&nbsp;</small> <small>&nbsp;</small> <small>&nbsp;</small></div>
<!-- nav toggle button for quick links for mobile -->

<div class="footer-links"><!-- Services -->
<div id="services">
<h3>Services</h3>

<nav>
<ul>
	<li><a href="/investment-services/">Account Types</a></li>
	<li><a href="/investment-services/">Premium Services</a></li>
	<li><a href="/stocks/zacks-rank">Zacks Rank</a></li>
	<li><a href="/stocks/">Research</a></li>
	<li><a href="https://finance.zacks.com">Personal Finance</a></li>
	<li><a href="/articles/">Commentary</a></li>
	<li><a href="/stock-education.php">Education</a></li>
	<li><a href="https://advisortools.zacks.com/">Zacks Advisor Tools</a></li>
</ul>
</nav>
</div>
<!-- My Account -->

<div id="my_account">
<h3>My Account</h3>

<nav>
<ul>
	<li><a href="/my-account/index.php">Manage Account</a></li>
	<li><a href="/my-account/login-info.php">Update Profile</a></li>
	<li><a href="/my_account/order_history.php">Subscriptions</a></li>
	<li><a href="/my-account/my-email.php">Preferences</a></li>
	<li><a href="/help/faq.php#s12">Login/Password Help</a></li>
	<li class="upgrade_premium_icid"><a href="/registration/premium/login/?continue_to=/registration/premium/trial/&amp;adid=zp_quicklinks_upgrade">Upgrade to Premium</a></li>
</ul>
</nav>
</div>
<!-- Resources -->

<div id="resources">
<h3>Resources</h3>

<nav>
<ul>
	<li><a href="/help/">Help</a></li>
	<li><a href="/about-zacks.php">About Zacks</a></li>
	<li><a href="/privacy.php">Privacy Policy</a></li>
	<li><a href="/registration/premium/welcome/eoffer/4f9f">Do Not Sell My Personal Information</a></li>
	<li><a href="/terms_of_service">Terms of Service</a></li>
	<li><a href="/performance_disclosure">Performance Disclosure</a></li>
	<li><a href="/accessibility-statement">Accessibility</a></li>
	<li><a href="/sitemap.php">Site Map</a></li>
	<li><a href="/podcasts?ADID=podcast_landingpage">Podcasts</a></li>
	<li><a href="/earnings/earnings-calendar">Earnings Calendar</a></li>
</ul>
</nav>
</div>
<!-- Client Support -->

<div id="client_support">
<h3>Client Support</h3>

<nav>
<ul>
	<li><a href="/contact">Contact Us</a></li>
	<li><a href="mailto:support@zacks.com">Share Feedback</a></li>
	<li><a href="/media-room/">Media</a></li>
	<li><a href="/careers.php">Careers</a></li>
	<li><a href="/advertising">Advertise</a></li>
	<li><a href="/reviews">Testimonials</a></li>
</ul>
</nav>
</div>
<!-- Follow Us -->

<div id="follow_us">
<h3>Follow Us</h3>

<nav>
<ul>
	<li id="facebook"><a href="https://www.facebook.com/ZacksInvestmentResearch">Facebook</a></li>
	<li id="twitter"><a href="https://twitter.com/ZacksResearch">Twitter</a></li>
	<li id="linkedin"><a href="https://www.linkedin.com">Linkedin</a></li>
	<li id="youtube"><a href="https://www.youtube.com/user/ZacksInvestmentNews">You Tube</a></li>
</ul>
</nav>
</div>
<!-- Zacks Moblie App -->

<div id="zacks_mobile_app">
<h3>Zacks Mobile App</h3>

<nav>
<ul>
	<li id="apple_store"><a href="https://itunes.apple.com/us/app/zacks/id731593509?mt=8" title="Download our Zacks App from the Apple App Store"><img width="135" height="40" alt="Download our Zacks App from the Apple App Store" src="https://linkmaker.itunes.apple.com/assets/shared/badges/en-us/appstore-lrg.svg" /></a></li>
	<li id="google_play_store"><a href="https://play.google.com/store/apps/details?id=com.zacks.androidapp&amp;utm_source=zacks.com&amp;utm_campaign=ZacksFooter&amp;pcampaignid=MKT-Other-global-all-co-prtnr-py-PartBadge-Mar2515-1" title="Download our Zacks App from Google Play"><img alt="Download our Zacks App from Google Play" height="60" src="https://play.google.com/intl/en_us/badges/images/generic/en_badge_web_generic.png" width="154" /></a></li>
</ul>
</nav>
</div>
</div>
</section>
</div>
<!--MSG:20703--><div id="zacks_reported">
<section>
<div id="partners">
<h2>Zacks Research is Reported On:</h2>

<ul>
	<li id="msn">MSN</li>
	<li id="marketwatch_reported">Marketwatch</li>
	<li id="nasdaq">Nasdaq</li>
	<li id="forbes">Forbes</li>
	<li id="investors">Investors.com</li>
	<li id="morningstar">Morningstar</li>
</ul>
</div>

<div id="a360-badge"><a aria-label="Reviewed by Accessible360" class="newwin" href="https://accessible360.com"><span aria-hidden="true" class="sr-only">Reviewed by Accessible360</span> </a></div>

<div id="bbb">
<div id="bbb-logo"><a class="newwin" href="https://www.bbb.org/chicago/business-reviews/financial-services/zacks-investment-research-inc-in-chicago-il-86000393/#sealclick" rel="nofollow"><img alt="Zacks Investment Research is an A+ Rated BBB Accredited Business" src="https://seal-chicago.bbb.org/seals/blue-seal-250-52-bbb-86000393.png" style="border: 0;" widget="250" height="52" /> </a></div>
</div>
</section>
</div>
<!--MSG:14023--><div id="copyright">
    <section>
        <p>This page has not been authorized, sponsored, or otherwise approved or endorsed by the companies represented herein. Each of the company logos represented herein are trademarks of Microsoft Corporation; Dow Jones & Company; Nasdaq, Inc.; Forbes Media, LLC; Investor's Business Daily, Inc.; and Morningstar, Inc.</p>
        <p>Copyright 2022 Zacks Investment Research <span aria-hidden="true">|</span> 10 S Riverside Plaza Suite #1600 <span aria-hidden="true">|</span> Chicago, IL 60606</p>
        <p>At the center of everything we do is a strong commitment to independent research and sharing its profitable discoveries with investors. This dedication to giving investors a trading advantage led to the creation of our proven Zacks Rank stock-rating system. Since 1988 it has more than doubled the S&P 500 with an average gain of +24.60%  per year. These returns cover a period from January 1, 1988 through August 1, 2022. Zacks Rank stock-rating system returns are computed monthly based on the beginning of the month and end of the month Zacks Rank stock prices plus any dividends received during that particular month. A simple, equally-weighted average return of all Zacks Rank stocks is calculated to determine the monthly return. The monthly returns are then compounded to arrive at the annual return. Only Zacks Rank stocks included in Zacks hypothetical portfolios at the beginning of each month are included in the return calculations. Zacks Ranks stocks can, and often do, change throughout the month. Certain Zacks Rank stocks for which no month-end price was available, pricing information was not collected, or for certain other reasons have been excluded from these return calculations.</p>
        <p>Visit <a class="in_copy" href="/performance_disclosure">Performance Disclosure</a> for information about the performance numbers displayed above.</p>
        <p>Visit <a class="in_copy newwin" href="http://www.zacksdata.com">www.zacksdata.com</a> to get our data and content for your mobile app or website.</p>
        <p>Real time prices by BATS. Delayed quotes by Sungard.</p>
        <p>NYSE and AMEX data is at least 20 minutes delayed. NASDAQ data is at least 15 minutes delayed.</p>
        <p id="recaptcha-statement">This site is protected by reCAPTCHA and the Google <a class="in_copy newwin" href="/privacy">Privacy Policy</a> and <a class="in_copy newwin" href="/terms_of_service">Terms of Service</a> apply.</p>
    </section>
</div><!--MSG:20963--><script>
var android_app_banner_conf = {
                    'appName': 'Zacks Stock Research',
                    'playStoreUrl': 'https://play.google.com/store/apps/details?id=com.zacks.androidapp',
                    'logo': 'https://lh5.ggpht.com/gFKFENaSeNSvMIE6vy2BPLE_JI3psqJnugt9WTapFttsptokO58NV6EilP0Kqgm7e00=w120',
                    'price': 'Free',
                    'category' : 'Finance',
                    'score' : '0.0'
                    }
</script>
<!-- z2_footer end -->

<!-- End: Footer -->
</footer>

<!-- bottomColl Part Start-->
<!-- z2_foot_module start -->

        <script language="JavaScript" type="text/javascript">
var dataLayer = {
                siteSection: 'BLOG'
            ,   loginStatus: 'Logged out'
            , siteType: 'desktop'
            ,   adidInternalCode : 'DEF'
            ,   pageIdentifier: "Is Most-Watched Stock Target Hospitality Corp. (TH) Worth Betting on Now?"
            ,   siteSubSection: 'BLOG:Tale of the Tape '
,   session_id: ''
            ,   ConfigID: ''
,tags : 'growth-investors,popular-stocks,trending-stocks'
                                    , blogID: { name: 'Is Most-Watched Stock Target Hospitality Corp. (TH) Worth Betting on Now?',
                                                id: '1981366',
                                                author : 'Zacks Equity Research',
                                                type : 'BLOG',
                                                section : 'Tale of the Tape',
                                                sub_section : 'Most Searched Stocks - V1',
                                                tickers : ['TH'],
                                                publish_date : '16/09/2022',
rich_media : []}
};
</script>
    <!-- Google Analytic Code -->
          <script>
         (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
         (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
         m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
         })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

         ga('create', 'UA-3472419-1', 'auto');
         ga('send', 'pageview');
         </script>  
          <!-- Google Analytic Code End --><!--
 * <p>This file is used for Yahoo remarketing pixel add </p>
 *
 * @package Generator
 * @subpackage Static
 *
 * @author Arpita Bannerjee
 *
 * @copyright (c) 2015 - 2016 Zacks Investment Research
 * @license   Internal Use only. No License granted.
 *
 * @filesource
 *
 *
-->

<script type="application/javascript">(function(w,d,t,r,u){w[u]=w[u]||[];w[u].push({'projectId':'10000','properties':{'pixelId':'22680'}});var s=d.createElement(t);s.src=r;s.async=true;s.onload=s.onreadystatechange=function(){var y,rs=this.readyState,c=w[u];if(rs&&rs!="complete"&&rs!="loaded"){return}try{y=YAHOO.ywa.I13N.fireBeacon;w[u]=[];w[u].push=function(p){y([p])};y(c)}catch(e){}};var scr=d.getElementsByTagName(t)[0],par=scr.parentNode;par.insertBefore(s,scr)})(window,document,"script","https://s.yimg.com/wi/ytc.js","dotq");</script><!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window, document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '532984783731823');
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none" alt="" src="https://www.facebook.com/tr?id=532984783731823&ev=PageView&noscript=1"/></noscript>
<!-- End Facebook Pixel Code -->
<!-- Start  Markit On Demand Code -->

<script defer type="text/javascript" src="https://ad.wsod.com/site/d84f59fb1c3d85c44bbd395dbecc5b45/0.0.async/"></script>

<!-- End  Markit On Demand Code -->
<!-- Start  Countdown Code -->

<section id="inactivity_warning" class="logout-timer--modal">

   <div class="modal-content">
      
            <h2 class="modal-title">
                Due to inactivity, you will be<br>signed out in approximately:  
            </h2>
       
      
          <div id="countdown"></div>
       
        <div class="modal-footer">
            <button class="green btn success" id="inactivity_btn_open">
              CLICK TO CONTINUE WORKING
            </button>
        </div>
       
   </div>
 
</section>
     

<!-- End  Countdown Code -->


<!-- daily data: 1663322496 -->
<!-- real-time data: 1663349760 -->

<!-- ELK JS -->
<script>
;(function(d, s, c) {
    var j = d.createElement(s),
        t = d.getElementsByTagName(s)[0]
    j.src = 'https://staticx.zacks.com/js/elk/elastic-apm-rum.umd.min.js'
    j.onload = function() {elasticApm.init(c)}
    t.parentNode.insertBefore(j, t)
})(document, 'script', {
    serviceName: 'Zacks Frontend',
    serverUrl: 'https://apm.zacks.com',
    serviceVersion: '20220624',
    transactionSampleRate: 0.1,
    environment: 'production'
})
</script>
<!-- z2_foot_module end -->

<!-- bottomColl Part End-->
</body>
</html>
